startsida < företaget < organisera < datorer < tips
 
Skapa arbetsschema

 
  Tabeller
Tabeller I
Tabeller II
Tabeller III
Tabeller IV
Tabeller V
Tabellfunktioner
Tabellhantering
Skapa arbets-
schema
   
  Innehåll
expowera

 

Materialet publicerat med tillstånd från Dennis Wallentin.

Att personalen lägger sina egna arbetsscheman är en vanlig företeelse idag. Det är också vanligt att vi använder oss av diverse beteckningar för olika arbetspass.

Det som kan upplevas vara svårt är att omvandla beteckningarna för arbets- passen till tider. Det i sin tur gör att det uppfattas som "knöligt" att samman- ställa personalens arbetade tid under en period.

Här i detta exempel, mer omfattande än andra, demonstreras ett sätt att skapa en struktur för att tillgodose informationsbehoven.

I första steget skapar vi ett arbetsschema, som omfattar en period av 3 veckor:

I nästa steg skapar vi en s k uppslagstabell:

Varje bokstav representerar ett pass med unik arbetstid.

Slutligen skapar vi en sammanställning över arbetad tid per anställd och arbetspass under perioden ifråga:

För att få fram summa arbetstid per anställd måste vi koppla samman alla tre tabellerna.

För att erhålla antalet gånger för respektive pass en medarbetare har arbetat under perioden används följande matrisformel:

  • {=SUMMA((Personal=$X3)*(Schematid=Y$2))}

Namnet "Personal" refererar till första kolumnen (cellområdet A4:A14) i arbetsschemat. "Schematid" refererar till cellområdet B4:V14 i samma tabell.

För att erhålla vad respektive bokstav representerar i antal timmar används följande formel:

  • LETARAD(Y$2;Pass;2;FALSKT)

Där namnet "Pass" refererar till området med enhetsbeteckningar och tidsangivelse i uppslagstabellen.

För att räkna fram antal timmar på basis av medarbetares namn och arbetspass sammanfogas dessa två formler i en cell:

  • =SUMMA((Personal=$X3)*(Schematid=Y$2))*LETARAD
    (Y$2;Pass;2;FALSKT)

Noterbart är att blandningen av relativa & absoluta cellreferenser möjliggör att kopiera såväl till höger i raden som nedåt i kolumnen.

Upp
Senast uppdaterad: 2005-10-05 © Dennis Wallentin